Ship Equpment not available from dock

Support for all Celsius Game Studios games.

Ship Equpment not available from dock

Postby MarkTwo » Sat Feb 08, 2014 4:45 am

I have installed the 0.4.3 release and noted a couple of issues.

First issue was that all of the commodities in the stock market had available quantity of -1, so unable to buy anything. This cleared after leaving and returning to the station.

Second problem involves ship equipment. I bought a collection (particle beams, plasma cannons, and machine guns) of weapons and stored them on the station, except for the plasma cannons which I installed on the ship leaving the lasers on the station. Upon return to the station, none of the weapons showed up in the station inventory while docked. However, they show up as being at the expected system while in Pilots Quarters -> Assets in any system where tried. Restarting/leaving and returning did not clear the problem. Subsequent weapons purchased do show up in the station inventory in the Dock, and I think in assets as well.
MarkTwo
 
Posts: 41
Joined: Fri Jan 17, 2014 10:44 pm

Re: Ship Equpment not available from dock

Postby CGSColin » Sun Feb 09, 2014 6:54 am

I don't suppose you'd mind sending the save file to contact@celsiusgs.com and let me know what system the missing assets are supposed to be in?
CGSColin
 
Posts: 962
Joined: Thu Oct 08, 2009 1:56 am

Re: Ship Equpment not available from dock

Postby MarkTwo » Sun Feb 09, 2014 9:11 pm

Of course, but since I added some history to this galaxy the problem is not as obvious. I have flown it back to the offending system (Xuvroq) for convenience. If you go to Pilot Quarters -> Assets -> Xuvroq -> Details you'll see that the inventory includes 2 plasma cannons, 4 particle beams, 2 machine guns, and 2 lasers. Go to Docking Bay -> (wrench) -> (blue box thing) and you'll see that the station inventory shows 2 particle beams, 2 machine guns, and 2 lasers. Missing when compared to the inventory shown in Assets are 2 plasma cannons and 2 particle beams. ( I realize that you probably have some gizmo so that you don't have to actually see the issue in-game, but you get my point.)

I had bought additional weapons that account for the presence of some weapons in station inventory. Hope that doesn't mess up the troubleshooting.

Also, I loaded a different save game and then attempted to reload this one in the same Drifter session and it crashed.

One other thing occurs to me. This galaxy was created in the previous version and this is the first use under 0.4.3, so perhaps it is an upgrade issue? Other possible red herrings to consider: available quantities for all commodities in the stock market were -1 initially, and the game crashed when attempting to save after running this save, loading a different save, and then trying to reload this save.
MarkTwo
 
Posts: 41
Joined: Fri Jan 17, 2014 10:44 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron